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NEMO 2.0 main objectives

• Make life easier for user by

– Giving the possibility to group actions in the Data tab

– Automating the filling of the Data tab where possible

– Create clear different process for CSV files with 
separators and TEXT files without  separators.

• Increase the amount of metadata in the CDI-
Summary file

• Assist the user  in the wrnting of batch commands
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General changes

• Help tab at the bottom of the main screen removed

– Replaced by access to the user manual in the '?' 

• Menu Right-click search function removed

– Replaced by a Search window for fields with a list of values

• Use of mouse wheel no longer results in changing 
values in already entered fields (like in Station tab for 
example)

• Display of line numbers in input file preview (except 
data tab if CSV file) 
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Changes on the File tab (1)

Reload button added:

Allows to reload the file 
after modifications without 
changing the template and 
without resetting all
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Changes on the File tab (2)

• Changes in Data column selection for CSV files
– Ability to enter multiple rows
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Goal

See more info in 
the data tab, in 

the column 
headings
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Changes on the File tab (3)

• Changes in Data column selection for CSV files
– allows for example to display the units if available in the input file
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Changes on the File tab (4)

• New field in Data column selection for CSV files
– Allows you to describe a row containing the parameter codes P01 or P09:
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GOAL

Automate the 
creation of 

parameter lines 
in the data tab
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Changes on Cruise tab (1)

• Changes in Data source
– Use of EDMERP codes of projects instead of free text 

label, several projects possible, loaded by XML 
initialisation or manual input - Possibility to add or 
remove projects
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GOAL

Increase data 
FAIRness by 

adding 
metadata
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Changes on the Cruise tab (2)

• Added as sdn_references in the output file:
<sdn_reference xlink:href="https://edmerp.seadatanet.org/report/12297" 
xlink:role="isObservedBy" xlink:type="SDN:L23::EDMERP"/>

<sdn_reference xlink:href="https://edmerp.seadatanet.org/report/11760" 
xlink:role="isObservedBy" xlink:type="SDN:L23::EDMERP"/>

• In the MedAtlas format, list of project codes (4 maximum, 
even if more in the cruise)
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Changes on the Station tab

• Station comment field increased to 1000 
characters instead of 500

• Addition of test field for the Sensor Depth 
field
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Changes on the Data tab

• "Drag and drop" possible to move parameters in 
the list

• Multi-lines selection possible: to set the same 
instrument, the same unit, the same format, the 
same default value…. to several parameters in a 
single action

• Possibility to automatically fill the parameter table 
under certain conditions

• Possibility to automatically fill the parameter and 
flag positions under certain conditions
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GOAL

Ease user life
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Automatic fill in of the parameter table (1)

• Only possible for
– CSV files containing P09 or P01 parameter codes

– If the line containing these codes has been filled in the File tab

• When these conditions are met a new "Auto-fill" menu is 
available in the data tab Menu 
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Automatic fill in of the parameter table (2)
• A click on the menu and the table of parameters is filled, it remains to 

check or add the formats and add if necessary the default values, the flags 
in input and the instruments used
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Changes in the data table menu
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Replaced

by

• suppressed because replaced by par drag and drop
• new Autofill functions
• new for multiple lines selections
• Set column number or set start/end
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Auto-fill next parameter positions (1)

– Possible only for

• CSV files

• If the list of parameters entered in the data table is in 
the same order as in the data file

• When the position of the 1st parameter has already 
been entered
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Auto-fill next parameter positions (2)
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1. Measured 

parameters 

one column out of 2

2. Parameters in the 

same order in the file 

and in the table of 

measurements

3. 1st parameter 

position already set

Input the position of the 

1st parameter
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Auto-fill next parameter positions (2)
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1. Measured 

parameters 

one column out of 2

2. Parameters in the 

same order in the file 

and in the table of 

measurements

3. 1st parameter 

position already set

Choose Auto-Fill next

parameter column
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Auto-fill next parameter positions (2)
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1. Measured 

parameters 

one column out of 2

2. Parameters in the 

same order in the file 

and in the table of 

measurements

3. 1st parameter 

position already set

Set the number of 

column to skip to read

the next position



sdn-userdesk@seadatanet.org – www.seadatanet.org

Auto-fill next parameter positions (2)

EMODnet Ingestion3 annual meeting, 12-13 april 2023, Larnaka, Cyprus

1. Measured 

parameters 

one column out of 2

2. Parameters in the 

same order in the file 

and in the table of 

measurements

3. 1st parameter 

position already set
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Autofill next parameter flags positions (1) 

– Possible only for

• CSV files

• If the list of parameters entered in the data table is in 
the same order as in the data file

• When the position of the 1st parameter flag has already 
been entered

– Same action than for the parameters
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Autofill next parameter flag position (2) 
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1. QC flags one column out of 2

2. Same order of pthe paramters

3. Position of the 1st flag already set

Input the position of the 

1st flag
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Autofill next parameter flag position (2) 
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1. QC flags one column out of 2

2. Same order of pthe paramters

3. Position of the 1st flag already set

Choose Auto-Fill next

parameter flags
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Autofill next parameter flag position (2) 
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1. QC flags one column out of 2

2. Same order of pthe paramters

3. Position of the 1st flag already set

Set the number of 

column to skip to read

the next position



sdn-userdesk@seadatanet.org – www.seadatanet.org

Autofill next parameter flag position (2) 
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1. QC flags one column out of 2

2. Same order of pthe paramters

3. Position of the 1st flag already set
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Delete an instrument (1) select the lines

– For one or more parameters depending on the 
number of lines selected
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Select the parameter lines
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Delete an instrument (2) choose Delete Instrument

– For one or more parameters depending on the 
number of lines selected
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Choose Delete instrument
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Delete an instrument (3) Result

– For one or more parameters depending on the 
number of lines selected
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Results
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Set the input default value (1) Select the lines

– For one or more parameters depending on the 
number of lines selected
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Select the parameter lines
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Set the input default value (2) choose set Input 
Default value

– For one or more parameters depending on the 
number of lines selected
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Choose Set Input Default Value
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Set the input default value (3) Input the default 
value

– For one or more parameters depending on the 
number of lines selected
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Set the Input Default Value, here ‘NaN’



sdn-userdesk@seadatanet.org – www.seadatanet.org

Set the input default value (4) Result

– For one or more parameters depending on the 
number of lines selected
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Results
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Changes during the conversion

• Station comments

– Station comments from CNV files can be taken into 
account

– Station comments are kept in ODV and added at the 
beginning of the file as comment lines 

• Flag 'B‘ (nominal value)  set on the pressure/depth of 
time series and trajectories if it is generated in the 
output file from the sensor depth
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New fields in the CDI-SUMMARY

• Used by MIKADO to generate CDI metadata

• Additional information
L05 (L22-L05 mapping) and L22 instrument codes, EDMERP 
codes, Cruise alternative name and CSR id, Cruise start date, 
Sampling rate and unit, Bounding box for trajectories, Station 
start and end date, Min and max measurement depth, Bottom 
depth

• Generation of a file allowing to draw the trajectory route in 
MIKADO MIKADO upgrading done to take into account this 
new file
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GOAL

Increase data 
FAIRness by 

adding 
metadata



sdn-userdesk@seadatanet.org – www.seadatanet.org

New  Batch Builder tool (1)

• to help the user in writing  batch procedures 
for NEMO, especially for a set of files using the 
same template but for different 
cruises/datasets

– Makes it easier to create a batch with arguments 
that vary from one file to another

– Arguments are listed in a CSV file: one line per file
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GOAL

Ease user life
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Batch Builder (2)
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• CSV mapping file

– Contains the 10 arguments of the batches to be 
launched, separated by ';‘

– One line per file

cruiseName cruiseComment localCsrIdentifier bshCsrReference cdiSummary shipCode

MADAGASCAR 2008 - LEG1 Tsg Beautemps-Beaupré cruise off Toamasina 8090050 summary_GOSUD_FI352008090050.txt35B5

FANINDIEN 2008 Tsg Beautemps-Beaupré cruise off Toamasina 8090070 summary_GOSUD_FI352008090070.txt35B5

MADAGASCAR 2008 - LEG2 Tsg Beautemps-Beaupré cruise off Toamasina 8090080 summary_GOSUD_FI352008090080.txt35B5

ESSNAUT 2009 TSG ESSNAUT 2009 cruise 9030020 summary_GOSUD_FI352009030020.txt35PK

fileNameIn modelName fileNameOut datasetRef

000486_ODV_GOSUD_FI352008090050.txt gosud_model_odv_Fanindien2008.xml output_GOSUD_FI352008090050_175rc18.txt FI352008090050

000486_ODV_GOSUD_FI352008090070.txt gosud_model_odv_Fanindien2008.xml output_GOSUD_FI352008090070_175rc18.txt FI352008090070

000486_ODV_GOSUD_FI3520080900780.txt gosud_model_odv_Fanindien2008.xml output_GOSUD_FI352008090080_175rc18.txt FI352008090080

000486_ODV_GOSUD_FI352009030020_TS.txt gosud_model_odv_Fanindien2008.xml output_GOSUD_FI352009030020_175rc18.txt FI352009030020
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Batch Builder (3)
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• Main screen, 2 
modes

– write batch 
command for one file
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Batch Builder (4)
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• Main screen, 2 modes

– write batch command 
for a directory with 
several files
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• Last developments 
finished

• Need some more tests

• Will be distributed 
soon (end of April –
Beginning of May) via 
SeaDataNet web site

NEMO 2.0 Status

Help desk

For any help, question : 

sdn-userdesk@seadatanet.org


